The VIPRE Business Premium agent will not install on a machine where VIPRE Internet Security was previously installed


PROBLEM

You find that you cannot install the VIPRE Business Premium agent after installing the VIPRE Internet Security. 

This problem can present itself in one of two ways:
 
  • You receive a warning message from the Windows installer indicating that the drivers could not be installed. The agent install will then roll back.
  • In a few rare cases, the Windows installer doesn't pop up the message. Instead, the installation process never completes and the agent install does not finish or cancel itself. 

ENVIRONMENT

  • VIPRE Business Premium
  • All Supported Environments

SOLUTION

Windows XP and Server 2003: 

  1. Navigate to C:\WINDOWS\inf\  
  2. Delete the Infcache.1 file
  3. Attempt to install the agent again

Windows Vista, 7 and Server 2008:


First, the driver must be deleted from all affected machines:
  1. Navigate to C:\Windows\System32\DriverStore\
  2. Take ownership of the INFCACHE.1 file
  3. Set permission for Everyone to Full Control
  4. Delete the file
Cached folders for the driver must also be removed: 
 
  1. Go to C:\Windows\System32\DriverStore\FileRepository\
  2. Find all of the folders starting with SBFWIM
  3. Take ownership of this folder and propagate ownership to all sub folders
  4. Set the permission for Everyone to Full Control
  5. Delete the folder
  6. Repeat this step for each folder starting with SBFWIM
  7. Attempt to install the agent again

CAUSE

The current version of VIPRE Internet Security has a different version of VIPRE"s firewall drivers than the business agent. Windows cached the VIPRE Internet Security driver and will not allow the VIPRE Business driver to be installed because of this cache version of the driver.