PROBLEM
Firewall shows disabled in the VIPRE User Interface
ENVIRONMENT
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VIPRE Business Premium
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VIPRE Internet Security | Home Premium
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All Supported Environments
SOLUTION
Follow these steps to isolate the problem with your firewall:
Firewall is disabled via settingsThe firewall may be disabled in the Firewall settings:
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Open the VIPRE user interface
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Click "Edit Settings" in the Firewall section
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Verify that "Enabled" has a check mark
Firewall is disabled despite being enabled in settingsIn some cases, the firewall will display as disabled in the VIPRE user interface even when the VIPRE tray icon and the firewall settings indicate that the firewall should be enabled. There are several things that need to be checked before this can be fixed.
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Verify that there are no other antivirus or firewall products installed and enabled on the system. Make sure that the Windows Firewall is also disabled.
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Check the Network adapters section of the Device Manager for any network related devices that are in a warning or error state. These devices must be removed or repaired if they are listed here. Please consult the manufacturer of the product that is referenced in the name of the device.
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In some cases, GFI Software Firewall NDIS IM Filter Miniport will be listed and in a warning or error state. A specialized tool must be used to remove these devices safely. Once they have been removed, VIPRE may need to be re-installed before the Firewall will enable again.
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While in the Device Manager, check the driver versions of the network adapters listed. Verify that the driver versions for these adapters are up to date.
Once all of the items above have been verified and repaired if necessary, we can re-apply the GFI Software Firewall NDIS IM Filter to all network adapters and re-enable the firewall from the VIPRE user interface:
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First, open the VIPRE user interface and click on "Edit Settings" in the firewall section.
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Remove the check mark next to "Enabled" to disable the firewall in the settings.
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Next, click Start>Run and type "ncpa.cpl" without quotation marks and press enter. You can also type the same thing into the Search bar on Windows Vista and 7 systems. The Network Connections control panel should open.
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Right click on a network connection and click Properties
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Remove the check mark from the item labeled "GFI Software Firewall NDIS IM Filter" and press the "OK" button.
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Open the properties for the same network connection again and place the check mark back on the item labeled "GFI Software Firewall NDIS IM Filter".
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Repeat this process for each network connection.
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Now we can open the VIPRE user interface and re-enable the Firewall
Firewall is still disabledIf this is the case, there could have been something that went wrong during the installation of the firewall drivers. This can be verified by analyzing the SetupApi.log file which logs driver installations in Windows. The file is located here:
Win 2000/XP:
C:\Windows
Win Vista/7:
C:\Windows\Inf
Search for the line of the installation log file that reads something as follows:
#-198 Command line processed: "C:\Program Files\GFI Software\VIPRE\sbsetupdrivers.exe" /install /HIPS /ARVA /FW
After this line, you will find information on the success of the installation. If you see any errors, these will need to be fixed before the installation can succeed and the firewall can be enabled.
SetupApi.log Errors#W059 Selecting best compatible driver failed. Error 0xe0000228: There are no compatible drivers for this device.This error occurs when the VIPRE agent is installed and it could not integrate the firewall driver with the network card(s) because Windows could not find any compatible drivers. This can often occur when there are remnant driver installation instructions in the "C:\Windows\Inf" folder or if the "C:\Windows\Inf\INFCACHE.1" file is corrupt. We'll need to have Windows replace this file and attempt to reinstall the Firewall drivers. To do so, follow these steps:
NOTE: Before following these steps, verify that there are no Sunbelt Firewall NDIS items in the device manager that are in error. If there are items in the device manager in error, please contact technical support.
Windows 2000/XP-
Delete any files that are of 0K in size.
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Rename the INFCACHE.1 file to INFCACHE.old
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Navigate to the Network Connections Control panel (Start>Run>Type "ncpa.cpl" and press enter).
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Right click on your network connection and click properties
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Verify that GFI Software Firewall NDIS IM Filter is listed, remove the check mark to disable it, and click OK.
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If it is not, click install, select services from the list, select GFI Software Firewall NDIS IM Filter from the list, and click OK.
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Open the VIPRE User Interface and make sure the firewall is disabled in the firewall settings (remove the check mark from Enable Firewall).
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Open a command prompt window with administrative privilages and navigate the command prompt to the VIPRE installation folder by typing cd "C:\Program Files\GFI Software\VIPRE" and press enter. (Note: The installation directory may be different in your installation. Verify the location before running these commands.)
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Type "sbsetupdrivers.exe /Install /FW" and press enter. The INFCACE.1 file should be recreated and new log information entered into the setupapi.log file.
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Close the command prompt and navigate back to the Network Connections Control panel to re-enable the GFI Software Firewall NDIS IM Filter
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Re-enable the Firewall in the VIPRE User Interface
Note: If the firewall does not re-enable, this means that the command did not install the necessary drivers. VIPRE will need to be re-installed at this point so that the drivers can be installed.
0x8004a029
This error indicates that the filter limit has been reached, thus, not allowing the VIPRE installation process to install additional filters that are required for the Firewall to function properly. To fix this problem, the easiest thing to do is to raise the maximum number of filters allowed by Windows. This can be done by modifying the following registry key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\MaxNumFilters
This key can safely be set to 14 and VIPRE can be installed again to make sure the filters are installed this time.
Firewall is in Error:In some cases the VIPRE firewall will display a status of Error in the VIPRE User Interface. If this is the case, there may have been something that caused the firewall driver or the GFI Software Firewall NDIS IM Filter to be disabled or removed. Here's what you can do to fix the problem:
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Open the Network Connections control panel (Start>Run>Type "ncpa.cpl" and press enter)
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Right click on your network connection and click properties
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Verify that GFI Software Firewall NDIS IM Filter is listed. If it is not, click install, select services from the list, select GFI Software Firewall NDIS IM Filter from the list, and click OK.
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Once this has been completed, we will need to verify that the firewall drivers are intact.
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Open a command prompt with administrative privilages.
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Type "sc query sbfw" and press enter
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You should get a response like the image below:

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If the STATE is instead STOPPED, type "sc start sbfw" and press enter to start the firewall service. Once it has started, open the VIPRE User Interface and attempt to re-enable the Firewall.
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If instead of the image above you receive a message that reads "The specified service does not exist as an installed service." this means that the driver is not available as an installed service. We will need to run the commands to reinstall the driver as a service.
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To do so, navigate the command prompt to the VIPRE installation folder by typing cd "C:\Program Files\GFI Software\VIPRE" and press enter. (Note: The installation directory may be different in your installation. Verify the location before running these commands.)
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Type "sbsetupdrivers.exe /Install /FW" and press enter. Then type "sc query sbfw" to verify that it has been installed. You should get the same results as displayed in step 7 except the state will likely be STOPPED. Follow the instructions in step 8 to start the service and re-enable the firewall from the VIPRE User Interface at this point.
CAUSE
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Software conflicts can block the firewall from applying the software driver to the network adapter.
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A problem with the installation process caused the software driver for network adapters to not install properly. This commonly occurs when too many connections have been processed in the history of the Windows installation and nothing has been done to clear the history of connections.
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Outdated network adapter drivers can be incompatible with the NDIS driver being installed with the Sunbelt Software Firewall NDIS IM Filter driver.
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The INFCACHE.1 file can sometimes get corrupt with normal Windows usage.